Blerter software is designed to runs seamlessly on most common systems and devices. This document outlines both minimum system requirements for Blerter to work as well as the recommend system versions to ensure Blerter is working at its best for you.

MOBILE REQUIREMENTS

Finding out which Version your phone is running

  1. From home screen (on both Android and iOS):

  2. Tap settings icon in top right corner

  3. Check the 'About' section/line which will display your current version number

  4. Tap 'About' for further…information on Privacy, Terms & Conditions etc. 

Updating Blerter to the latest version

Both the Google Play and App Store will send a notification (depending on your phone settings) when there are newer version of Blerter available for download. 

If you can’t update it straight away that’s not a problem - just jump back into your Store before the event so you can download the latest version and get the most out of the Blerter experience. 

Blerter Mobile App Requirements 

Android

  • Minimum: Version 5.1

  • Recommended: Version 10 + or the latest version where possible

iOS

  • Minimum: iOS 11 

  • Recommended: The latest version of iOS 

DESKTOP REQUIREMENTS

The Blerter Desktop App is built on Vaadin, a Java web application development framework. One of the advantages of using Vaadin is that the platform doesn't block any browsers and does not require any browser plugins. 

Operating System

Our Desktop App does not require any specific operating system. Only a modern web browser is required.

Supported Browsers

  •  Blerter Desktop is accessible via all common web-browsers 

We recommend using the latest version of one of the top browsers listed below as more testing is done on these platforms: 

  • Mozilla Firefox (latest) 

  • Mozilla Firefox ESR (latest) 

  • Internet Explorer 11, 

  • Edge (latest) 

  • Safari 9+ o Google Chrome (latest) 

  • iOS 10+ 

  • Android 4+ with Chrome 42+ 

Did this answer your question?